unitas-letsencrypt/app-crypt/certbot-dns-hetzner/certbot-dns-hetzner-1.0.5.e...

32 lines
877 B
Bash

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=(python3_8 python3_9 python3_10)
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/ctrlaltcoop/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/ctrlaltcoop/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 x86"
fi
inherit distutils-r1
DESCRIPTION="Hetzner DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
HOMEPAGE="https://github.com/ctrlaltcoop/certbot-dns-hetzner"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
app-crypt/certbot[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}"