unitas-mail/dev-python/recurring-ical-events/recurring-ical-events-0.1.1...

34 lines
946 B
Bash

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
DESCRIPTION="A Python module which repeats ICalendar events by RRULE, RDATE and EXDATE."
HOMEPAGE="https://github.com/niccokunzmann/python-recurring-ical-events"
SRC_URI="https://github.com/niccokunzmann/python-${PN}/archive/v${PV}b0.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 x86"
RDEPEND="
dev-python/icalendar[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
S=${WORKDIR}/python-${P}b0
##python_prepare_all() {
## # reset conf.py to not read version from an installed instance
## sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
## -i docs/conf.py || die
## distutils-r1_python_prepare_all
##}