28 lines
656 B
Bash
28 lines
656 B
Bash
# $Header: $
|
|
|
|
EAPI="8"
|
|
|
|
PYTHON_COMPAT=( python3_{7,8,9,10,11,12,13} )
|
|
inherit python-r1
|
|
|
|
DESCRIPTION="Convert VMware .vmdk images, build .ovf and .ova"
|
|
HOMEPAGE="https://github.com/vmware/open-vmdk"
|
|
|
|
SRC_URI="https://github.com/vmware/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
|
|
KEYWORDS="amd64 x86"
|
|
|
|
LICENSE="Apache-2.0"
|
|
SLOT="0"
|
|
|
|
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
|
|
|
|
RDEPEND="${PYTHON_DEPS}"
|
|
DEPEND=${RDEPEND}
|
|
|
|
src_install() {
|
|
emake DESTDIR="${D}" install || die "install failed"
|
|
|
|
newbin ovf/mkovf.py mkovf || die "newbin failed"
|
|
python_replicate_script "${ED}"/usr/bin/mkovf || die "python_replicate_script failed"
|
|
}
|