unitas-misc/dev-embedded/lpc21isp/lpc21isp-1.97.ebuild

29 lines
553 B
Bash

# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit linux-info versionator
MY_PN="${PN}_$(delete_all_version_separators)"
DESCRIPTION="In-circuit programming (ISP) tool for the NXP microcontrollers"
HOMEPAGE="https://sourceforge.net/projects/lpc21isp/"
SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND=""
S=${WORKDIR}/${MY_PN}
CONFIG_CHECK="~USB_SERIAL_CP210X"
src_install() {
dobin lpc21isp
}