unitas-misc/www-apps/lektor-atom/lektor-atom-0.4.0.ebuild

31 lines
733 B
Bash

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python{3_8,3_9,3_10,3_11} )
inherit distutils-r1
DESCRIPTION="Lektor Atom plugin."
HOMEPAGE="https://www.getlektor.com/plugins/lektor-atom/"
SRC_URI="https://github.com/lektor/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="AGPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND="www-apps/lektor
dev-python/feedgenerator[${PYTHON_USEDEP}]
dev-python/markupsafe[${PYTHON_USEDEP}]"
RDEPEND=""
DOCS=( CHANGELOG.md README.md )
pkg_setup() {
if [[ ${PV} != 9999 ]]; then
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
fi
}