26 lines
605 B
Bash
26 lines
605 B
Bash
# Copyright 1999-2021 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
|
|
PYTHON_COMPAT=( python3_{8..12} )
|
|
PYPI_NO_NORMALIZE=1
|
|
PYPI_PN="Flask-SQLAlchemy"
|
|
inherit distutils-r1 pypi
|
|
|
|
DESCRIPTION="SQLAlchemy support for Flask applications"
|
|
HOMEPAGE="https://pypi.org/project/Flask-SQLAlchemy/"
|
|
|
|
LICENSE="BSD"
|
|
SLOT="0"
|
|
KEYWORDS="amd64 ~arm ~arm64 x86"
|
|
|
|
RDEPEND="
|
|
<dev-python/flask-2[${PYTHON_USEDEP}]
|
|
<dev-python/sqlalchemy-2[${PYTHON_USEDEP}]
|
|
"
|
|
|
|
distutils_enable_tests pytest
|
|
distutils_enable_sphinx docs dev-python/pallets-sphinx-themes \
|
|
dev-python/sphinx-issues
|