unitas-privacyidea/dev-python/flask-versioned/flask-versioned-0.9.4.ebuild

43 lines
887 B
Bash

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
MY_PN="Flask-Versioned"
MY_DATE="20101221"
MY_P="${MY_PN}-${PV}-${MY_DATE}"
DESCRIPTION="Add version info to file paths."
HOMEPAGE="https://github.com/pilt/flask-versioned"
SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-python/namespace-flaskext[${PYTHON_USEDEP}]
>=dev-python/flask-0.9[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"
S="${WORKDIR}/${MY_P}"
python_test() {
esetup.py test || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die
}