19 lines
663 B
Bash
19 lines
663 B
Bash
# Copyright 1999-2021 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
|
|
EAPI=7
|
|
|
|
PYTHON_COMPAT=( python3_{7..12} pypy3 )
|
|
|
|
inherit python-r1
|
|
|
|
DESCRIPTION="A virtual for the Python cffi package"
|
|
SLOT="0"
|
|
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
|
|
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
|
|
|
|
# built-in in PyPy and PyPy3
|
|
RDEPEND="${PYTHON_DEPS}
|
|
$(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')"
|