unitas/app-admin/keepassx/keepassx-2.0.2-r90.ebuild

44 lines
951 B
Bash

# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
EGIT_REPO_URI="https://github.com/kylemanna/keepassx"
EGIT_COMMIT="e0e96ce0fb053d2ec58ec8257136f100683ffe63"
EGIT_BRANCH="yubikey"
inherit git-r3 cmake-utils
DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
HOMEPAGE="http://www.keepassx.org/"
SRC_URI=""
LICENSE="|| ( GPL-2 GPL-3 ) BSD GPL-2 LGPL-2.1 LGPL-3+ CC0-1.0 public-domain || ( LGPL-2.1 GPL-3 )"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="test yubikey"
DEPEND="
dev-libs/libgcrypt:0=
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qttest:5
dev-qt/qtx11extras:5
sys-libs/zlib
x11-libs/libX11
x11-libs/libXtst
yubikey? ( sys-auth/libyubikey
sys-auth/ykpers )
"
RDEPEND="${DEPEND}"
DOCS=(CHANGELOG)
src_configure() {
local mycmakeargs=(
-DWITH_TESTS="$(usex test)"
)
cmake-utils_src_configure
}